
KYTC CUSTOM XML REPORT HELP 

Last Updated: 5/6/14 

KYTC_CC_Alignments.xsl 

 

The KYTC_CC_Alignments style sheet is set up to report Geometry data in tabular format for 
inclusion on KYTC Coordinate Control sheets.  This report formats XML files created through the 
Geometry option under XML Reports.  It reports only on Horizontal Alignments; vertical 
alignments and COGO points are not supported with this style sheet.  This style sheet cannot 
handle reporting for curves with more than two centers.  If your alignment has a three-center 
curve or more, you will have to get that data through other methods. 

 

You can change the precision of most of the data by going to “Tools>Format Options” in the 
Report Browser.  General convention has the Northing and Easting reported to three (3) digits 
while the Elevation, Station and Offset are reported to two (2) digits. 

 

This information must be exported to Microsoft Excel.  If you right-click on the body of the style 
sheet table, close to the bottom is an option to “Export to Microsoft Excel”.  Doing this will 
create an unnamed Excel file with the table data which you will want to save.  At this point, you 
can run the “Coordinate Control” macro in the KYTC MicroStation workspace to build the 
coordinate control tables and create the Coordinate Control CSV file. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top. 
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KYTC_CC_Control.xsl 

 

The KYTC_CC_Control style sheet is set up to report COGO Point data in tabular format for 
inclusion on KYTC Coordinate Control sheets.  This report formats XML files created through the 
Clearance option under XML Reports.  It reports only on COGO Points; horizontal and vertical 
alignments and surface features are not supported with this style sheet.  If the Station and 
Offset data for a point is blank, it is most likely due to the fact that the point is beyond the 
limits of the horizontal alignment used for the clearances.  

 

The Description column reports the “Description” field of the COGO Point.  It is recommended 
to place the Control Point or Benchmark number here (CP 1, BM 3, etc). 

 

You can change the precision of most of the data by going to “Tools>Format Options” in the 
Report Browser.  General convention has the Northing and Easting reported to three (3) digits 
while the Elevation, Station and Offset are reported to two (2) digits. 

 

This information must be exported to Microsoft Excel.  If you right-click on the body of the style 
sheet table, close to the bottom is an option to “Export to Microsoft Excel”.  Doing this will 
create an unnamed Excel file with the table data which you will want to save.  At this point, you 
can run the “Coordinate Control” macro in the KYTC MicroStation workspace to build the 
coordinate control tables and create the Coordinate Control CSV file. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.  
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KYTC_CC_RWMonuments.xsl 

 

The KYTC_CC_RWMonuments style sheet is set up to report COGO Point data in tabular format 
for inclusion on KYTC Coordinate Control sheets.  This report formats XML files created through 
the Clearance option under XML Reports.  It reports only on COGO Points; horizontal and 
vertical alignments and surface features are not supported with this style sheet.  If the Station 
and Offset data for a point is blank, it is most likely due to the fact that the point is beyond the 
limits of the horizontal alignment used for the clearances.  

 

You can change the precision of most of the data by going to “Tools>Format Options” in the 
Report Browser.  General convention has the Northing and Easting reported to three (3) digits 
while the Elevation, Station and Offset are reported to two (2) digits. 

 

This information must be exported to Microsoft Excel.  If you right-click on the body of the style 
sheet table, close to the bottom is an option to “Export to Microsoft Excel”.  Doing this will 
create an unnamed Excel file with the table data which you will want to save.  At this point, you 
can run the “Coordinate Control” macro in the KYTC MicroStation workspace to build the 
coordinate control tables and create the Coordinate Control CSV file. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.  
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KYTC_ComponentVolume.xsl 

 

The KYTC_ComponentVolume style sheet is set up to report template component areas and 
volumes in tabular format.  This report formats XML files created through the End Area 
Volumes option under Cross Section>Cross Sections.  It reports end areas for each template 
component viewed on the cross sections (asphalt blocks, subgrades, etc.).  If rock classifications 
are viewed on the cross sections, these areas and volumes will be broken out by surface name.  
It also reports the end area volumes between cross sections for those components.   

 

You can change the precision of the data by going to “Tools>Format Options” in the Report 
Browser. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.   



KYTC CUSTOM XML REPORT HELP 

Last Updated: 3/14/14 

KYTC_DDA Point Discharge.xsl 

 

The KYTC_DDA Point Discharge sheet is set up to report COGO Point data in tabular format for 
KPDES/eNOI reports.  This report formats XML files created through the Clearance option under 
XML Reports.  It reports only on COGO Points; horizontal and vertical alignments and surface 
features are not supported with this style sheet.  This style sheet reports the Latitude and 
Longitude of the selected COGO Points based off the Northing and Easting of the point and the 
Geographic Coordinate System applied to the active DGN file.  

 

The Point Discharge column reports the “Description” field of the COGO Point.  It is 
recommended to place the DDA number in the description field. 

 

You cannot change the precision of the Latitude or Longitude through the Report Browser 
window.  To change the precision of these values, you must do so in the DGN file under 
Settings>Design File>Angle Readout>Accuracy.  You can also change between decimal degrees 
and degrees, minutes, seconds readout here.  The eNOI requires this information reported in 
decimal degree format. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.   
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Last Updated: 3/14/14 

KYTC_DDA Point Discharge_wNorth-East.xsl 

 

The KYTC_DDA Point Discharge_wNorth-East sheet is set up to report COGO Point data in 
tabular format for KPDES/eNOI reports.  This report formats XML files created through the 
Clearance option under XML Reports.  It reports only on COGO Points; horizontal and vertical 
alignments and surface features are not supported with this style sheet.  This style sheet 
reports the Latitude and Longitude of the selected COGO Points based off the Northing and 
Easting of the point and the Geographic Coordinate System applied to the active DGN file.  

 

The Point Discharge column reports the “Description” field of the COGO Point.  It is 
recommended to place the DDA number in the description field. 

 

You cannot change the precision of the Latitude or Longitude through the Report Browser 
window.  To change the precision of these values, you must do so in the DGN file under 
Settings>Design File>Angle Readout>Accuracy.  You can also change between decimal degrees 
and degrees, minutes, seconds readout here.  The eNOI requires this information reported in 
decimal degree format. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.  
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KYTC_EndAreaVolume.xsl 

 

The KYTC_EndAreaVolume style sheet is set up to report cut and fill areas and volumes in 
tabular format.  This report formats XML files created through the End Area Volumes option 
under Cross Section>Cross Sections.  It reports total end areas for cut and fill on each cross 
section.  It also reports the end area volumes between cross sections for cut and fill as well as 
the Mass Ordinate for the cross section.   

 

You can change the precision of the data by going to “Tools>Format Options” in the Report 
Browser. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top.  
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KYTC_EndAreaVolume_wComponent.xsl 

 

The KYTC_EndAreaVolume_wComponent style sheet is set up to report cut and fill areas and 
volumes as well as template component areas and volumes in tabular format.  This report 
formats XML files created through the End Area Volumes option under Cross Section>Cross 
Sections.  It reports total end areas for cut and fill on each cross section as well as the area for 
each template component viewed on the cross sections (asphalt blocks, subgrades, etc.).  If 
rock classifications are viewed on the cross sections, these areas and volumes will be broken 
out by surface name.  It also reports the end area volumes between cross sections for the cut 
and fill and components as well as the Mass Ordinate for the cross section.    

 

You can change the precision of the data by going to “Tools>Format Options” in the Report 
Browser. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top. 
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KYTC_Geotech Cood Data.xsl 

 

The KYTC_Geotech Coord Data style sheet is set up to report COGO Point data in tabular format 
for the KYTC Geotechnical Branch Coordinate Data Submission table.  This report formats XML 
files created through the Clearance option under XML Reports.  It reports only on COGO Points; 
horizontal and vertical alignments and surface features are not supported with this style sheet.  
This style sheet reports the Latitude and Longitude of the selected COGO Points based off the 
Northing and Easting of the point and the Geographic Coordinate System applied to the active 
DGN file.  

 

The “Hole Number” column is reporting on the “Point Number” of the COGO Point.  The COGO 
Point number should match up with the Geotech Boring Number. 

 

You cannot change the precision of the Latitude or Longitude through the Report Browser 
window.  To change the precision of these values, you must do so in the DGN file under 
Settings>Design File>Angle Readout>Accuracy.  You can also change between decimal degrees 
and degrees, minutes, seconds readout here.  KYTC Geotechnical Branch requires this 
information reported in decimal degree format.  It is recommended to report the data to six (6) 
digits. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top. 
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KYTC_HorizontalAlignmnetCurveSetReview.xsl 

 

The KYTC_HorizontalAlignmentCurveSetReview style sheet is set up to report Geometry data.  
This report formats XML files created through the Geometry option under XML Reports.  It 
reports only on Horizontal Alignments; vertical alignments and COGO points are not supported 
with this style sheet.  This style sheet cannot handle reporting for curves with more than two 
centers.  If your alignment has a three-center curve or more, you will have to get that data 
through other methods. 

 

You can change the precision of most of the data by going to “Tools>Format Options” in the 
Report Browser. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top. 
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KYTC_SUE Summary.xsl 

 

The KYTC_SUE Summary style sheet is set up to report COGO Point data in tabular format for 
the Quality Level “A” Data Summary table for inclusion in the plan set.  This report formats XML 
files created through the Clearance option under XML Reports.  It reports only on COGO Points; 
horizontal and vertical alignments and surface features are not supported with this style sheet.  
This style sheet reports the Latitude and Longitude of the selected COGO Points based off the 
Northing and Easting of the point and the Geographic Coordinate System applied to the active 
DGN file.  

 

The “Test Hole” column is reporting on the “Point Number” of the COGO Point.  The COGO 
Point number should match up with the Test Hole Number.  The “Utility” column reports the 
“Description” field of the COGO Point.  It is recommended to use this field to enter the size and 
type of utility located.  The “Ground Elevation” column is reporting the elevation of the COGO 
Point.  Ensure that the elevation of the COGO Point in InRoads is actually the existing ground 
elevation and NOT the top of utility elevation. 

 

You can change the precision of most of the data by going to “Tools>Format Options” in the 
Report Browser. 

 

If you right-click on the body of the style sheet table, close to the bottom is an option to 
“Export to Microsoft Excel”.  Doing this will create an unnamed Excel file with the table data. 
Once the data is in the Excel file, you will need to manually complete the “Top Utility 
Elevation”, “Depth”, “Surface Type” and “Remarks” columns for each test hole. 

 

With each style sheet, there is some help documentation.  To access this information, select the 
style sheet name on the lefts-side of the Report Browser window and right-click and select 
“Style-Sheet Help” at the top. 


