_ initi TEAM
KYTC — How to Create a Feature Definition KENTUCKY
1. Create the 2D Cell for Plan View
a. Ifyou can find something in a cell library that already exists (close to what you are making),
may be best to copy over and modify.
b. Make sure it looks close to what the Standard Drawing or Detail Drawing looks like
¢. KYTCDrainage.cel is with KYTC CADD Standards. This will get overwritten when new
standards are released, so we do NOT recommend placing your new cell here.
i Suggest creating a new *.cel library in:
C:\KYTC_Standards\Organization-Civil\KYTC_Standards_OC\_Roadway\_Drainage\Cell
d. Make sure the cell is on the default level, and that the color, line weight, and line type are on
‘By Level’ for the cell you are creating. To do this through the ‘Element Template’.
i Go to the ‘Home’ tab, then to ‘Attributes’
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ii. The image above shows the level set to ‘default’, and the color, line weight,
and line type set to ‘By Level’
e. Each cell must have:
i.  An ‘alignment point’. This is the point you want the cell to rotate about when you
place it.

1. Use the Element Template
a. Go to ‘Drainage’>'Element Template’>’Alignment Point’.
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b. This will place the attributes on a line style and color of 3 (red).
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2. Now go to ‘Drawing’>'Placement’ and select the ‘Point’ icon
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3. Place the Alignment Point.
ii. Next, place an ‘alignment line’. This is the point and line that the 2-D ‘Plan View’ cell
will reference to determine how the cell is rotated.
1. Go to ‘Drainage’>’Element Template’>’Alignment Line’. This also on a
line style and color of 3 (red).
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2. Now go to ‘Drawing’>'Placement’ and select the ‘Place Line’ icon
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3. Place the Alignment Line. Note that this should be drawn in the
direction you want the cell to face at zero rotation.

iii.  A‘node location point’. This is the point that the 2-D ‘Plan View’ cell will be placed
(centered) about —i.e. the position defined by the coordinates used when the node is
placed.

1. Go to ‘Drainage’>’Element Template’>Node Location Point’. This is on
line style 4 and color 4 (yellow).

2. Now go to ‘Drawing’>'Placement’ and select the ‘Point’ icon.

3. Place the node location point
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iv.  Anexample of all 3 is shown below:

1. Please note that in 10.12, the lines that represent the pipe vault for
drainage structures will have to be drawn into the 2D plan view after the
design is complete.
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2. Create the 3D Top Phase
a. The 3D drainage drawings are in KYTC_3D_Drainage.cel. Remember, if this is something
you intend to use again, it might be a good idea to start a new 3D file or copy this file
over to another name, so it doesn’t get overwritten when new KYTC CADD Standards
come out.
b. You will need to know how to draw in 3D.
i This needs to use the ‘Modeling’ workflow.
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ii. You will need to become familiar with how to use design groups such as the
‘Solids’ and ‘Surfaces’ groups. Make the cell look reasonably close to the
detail or Standard Drawing you are using.

=l | Modeling - @ HEE « - f2@H@ - CAKYTC_Standards\Organization-Civil KYTC_Standards_OC\_Roadway\ Drainage\Cel\K¥TC_3D Drainage.cel [3D - V2 D(
IE tome  View  Cumes | Solids  Sufaces  Mesh  Content  Anslyze  Constraints  Utilies  DrawingAids  Collsborate  Help

(= M A=) =9 D e a3 T (@ Q (“lj 51 S = "‘) B AP g @ Unite B 7= &
ClHQAMZAL W HINPOP@FeoID® PIRIL @ B 3
Slab [Cylinder Sphere Cone Torus Linear Extrude Extrude Thicken Revolve Loft ~ Cut  Fillet Chamfer Hole Protrude Shell Sweep Imprint Taper Spin Edit Medify Trim Delete Associative o
- - Solid “Along Edge Face Face Festure Solid Solid (&l Intersect Piece @+ Extraction &
Primitives Create Solids Features Modify Features Solid Utilities
T3
Y
Explorer r1x )
= View 2, Top - Example
@ File PO HemEa=m ST
¥ Items v
| v y @ L [ = . R
Modeling v ; = & 5ol - CAKYTC_Standards\Organization-Civil\KYTC_Standards_OC\_Roadway_

Mesh Content Analyze Constraints Utilities Drawing Aids Collaborate Help

3 $p O 31 2 BE EF 5 if : (& &= > «; i

: 7
tract Compute =

Home View Curve;

A A
r

Construct  Loft rExtrut:le Revolve  Primitive Tim  Fillet Blend Extend Offset Merge Stitch / Split  Surface b Change planar Ex &
Surface - N {Sweep~ Surface~ Surfaces~ N T Surfaces Surface Surface To Edge Combine~ surface Handlebar <« 5Surface~  glice N Surface ™ gy
Create Surfaces Modify Surfaces Surface Utilities

2§

L
Explorer v ox _

ut View 2, Top - Example

File p—

\d Dlﬁlﬁ iy = E B | & T G

¥ Items hd

iii. As you develop the cell, it is recommended that elements, solids and surfaces
be drawn on the ‘default level’, and ‘by level’ for color and line weight.
c. Once you have drawn the cell, you will need to place:
i The ‘alignment point’ and ‘alignment line’.
1. Use the ‘Element Template’ command to place as in the 2D cell.
2. The ‘alignment point’ should be located where the 3D top phase and 3D
bottom phase cells will connect.
3. The ‘alignment line’ needs to be in the same direction as the 2D cell.
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ii. Top elevation point

1. This will be the point that is placed relative to the proposed

terrain/corridor. For instance, this will be the gutter point on the curb
inlet.

2. Online style 5 (level 5 and color 5 as well).

/
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3. Create the 3D Bottom Phase
a. Thisis usually a vault.

vi.

Needs to be on ‘default level’, and ‘by level’ for color and line weight.

Has x,y,z dimensions.

Make sure the inside and OUTSIDE dimensions are accounted for. This should
cover wall thickness.

Consider height requirements/minimum depth requirements of the vault (e.g.,
Standard Drawing RDB-410).

Make sure the thickness of the top of the vault, side walls, and bottom slab is
accounted for per the standard or detail drawing.

Standard Drawing RDB-410 is a good start. KYTC already has these in the KYTC
Standards, so you may want to start with one of these, and if modification is
necessary, copy over and change accordingly.

b. Once the lower phase is created you will need to place:

The ‘alignment point’, ‘alignment line’, and the ‘bottom elevation point’
This is done in the same manner as the top phase.
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Note that the location point and location line are placed in the Z = 0 plane.
This is the element that will be extruded up, which emulates stretching the
vault or stretching a riser from a vault to the top phase. Extrusion is covered
later in this section.

The location of the ‘alignment point” and ‘alignment line’ should be so that the
bottom phase will fit to the point and be rotated relative to the top phase.

The elevation point for the bottom 3D cell will be used for the ‘invert
elevation’ for the drainage structure.
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c. Connection regions
i To be able to connect pipes, the bottom 3D cell must have connection regions.

1. These will be placed at the point in the vault (or headwall) where the
pipes will attach.

2. Use the Element Template for ‘Connection Region’ (placed on color 6
and line style 6)

3. Athin rectangle should be used.

a. Placed at the INSIDE of the vault or headwall.

b. Centered on wall where the end of the pipe attaches.

c. Bottom of square/rectangle should be at the invert/floor of the
vault.

d. The height and width of the rectangle is up to the user, however
the insertion of the pipe will slide along the bottom width of the
square, so the thinner it is, the less likely the pipe will be off the
chamber center.

d. Extrusion (stretching one of the cells up or down to the other one).

i Bentley default has it set where the bottom cell extrudes UP. You can change
this in the KYTC_Standards_OC.cfg file, found in
C:\KYTC_Standards\Organization-Civil.

ii. Itis in the #SU_3D_Structure_Extrude (Line 496). You will see the line is
commented out with a hashtag symbol. This sets the default for the bottom
cell to extrude up. If the hashtag is removed, then the top cell extrudes down.

iii. Note that the face/plane that is on the Z=0 plane will be the item that is
stretched.

1. Since KYTC prefers stretching the bottom phase up to the top phase, the
very top of element in this cell is placed in the z=0 plane.
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2. This will also be the plane where the ‘location point’ and ‘location line’
will be located.

3. Inthe example below, a small height of a riser for the inlet is drawn on
top of the main chamber. The top of this element is placed on the z=0

plane, meaning the top face of the riser will stretch that element so the

location point and line intercepts the location point and line on the top
phase.




_ initi TEAM
KYTC — How to Create a Feature Definition KENTUCKY
4. Create a Catalog Entry for Feature Definition

a. Thisis only necessary for inlet feature definitions. Manholes don’t need this.

i Physical data used to determine hydraulic functionality of these structures is
located here.

b. This must be done in a 2-D file as well. KYTC recommends creating a new 2D design file
using the C:\KYTC_Standards\Organization-
Civil\KYTC_Standards_OC\_KYTC\Seed\KYTC_ORD_2D_ Seed.dgn

c. Click on the ‘Components’ ribbon and select the ‘Catalog’ pulldown. Select ‘Inlet
Catalog’
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d. Ifthereis aninlet similar to the one being created, it is recommended to ‘Duplicate’ the
one that exists and modify it. Otherwise, select ‘New’. Name (or rename if duplicated)
logically so you know what it is and can find this later in the process.

e. For KYTC, there are 3 basic types of inlets:

i Grate
ii. Curb
iii. Combination
iv.  This is selected under the ‘Inlet’ tab, with the ‘Inlet Type’ Button

f.  The ‘Structure Width’ and ‘Structure Length’ refer to the inner dimensions of the
structure vault.

i For KYTC inlet vaults, the ‘Structure Length’ is the X dimension in Standard
Drawing RDB-410. This is the longitudinal dimension, which runs parallel to
the centerline of the road.

ii.  The ‘Structure Width’ is the Y dimension in Standard Drawing RDB-410. This is
the cross-sectional dimension, which runs perpendicular to the centerline of
the road.
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Dimensions for curb heights, throats, local gutter depressions and gutter depression
widths, and grate widths and lengths can be found in the KYTC Standard Drawings

h. The ‘Design’ Tab next to the ‘Inlet’ tab allows the user to specify the lengths of throated
in lets, such as KYTC Type A and Type B inlets (5, 10, 15, and 20 feet).
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5. Create the ‘Prototype’ for the structure.

a. Click on the ‘Components’ ribbon and select the ‘Prototype’ pulldown.
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i As you can see, there are several structure types to choose from, including:

1. Conduits

2. Channels

3. Gutters

4. Catch Basins
5. Manholes

6. Headwalls
ii. Select the type of structure you want to create.

1. Again, it is generally easier to copy over a similar structure to the one
you are creating.

2. As before, ‘Duplicate’ the one that exists and modify it. Otherwise,
select ‘New".

3. Again, name logically so you know what it is and can find this later in the
process.

4. Note: In the currently used version of ORD (10.12), the user is not able
to rearrange the prototypes in the list. The order they are created is the
order they are displayed.
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Double click on the prototype you just created. The ‘Properties’ dialog will
appear for that prototype.

1.

Under ‘Design’, set the parameters as displayed above.

2. Make sure under ‘Physical (Structure Losses), the settings are as
displayed below.
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3. Make sure the properties under the ‘Physical’ section are correct for
your structure.
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6. Assign the catalog entries to the prototypes (for inlets, gutters, conduits, and culverts only).

a. You should still be in ‘Components’ ribbon, in the 'Prototypes’ interface.

b. Under ‘Catch Basin’, then go to the ‘Catch Basin’ subcategory’.
c. Double click on the prototype you created in the previous step.
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d. Under the ‘Drainage Properties’ tab, go to the ‘Inlet’ section

e. Under ‘Inlet Type’ Select ‘Catalog Inlet’

f. Under ‘Inlet’, select the inlet you just created. This is selecting the catalog entry
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7. Create the Element Templates
a. Make sure you are still in the new 2D design file you created in Step 4 — ‘Create a Catalog
Entry for Feature Definition.
b. Goto ‘Element Template Manager’

i Same place we found the default color and line style for the location points
and lines. At the very bottom of that pulldown, you will see a button that says
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ii.  Selectthe new DGN file that was created in Step 4.
iii. Select the group you want to put the feature definition will be in
1. E.g. Acurbinlet Type ‘B’ would be under ‘Drainage>Storm
Nodes’>’Inlets’>'Curb Inlets’>'Type B’
2. A new group can be created at whatever level you deem necessary. For
instance, you may want a ‘Non-KYTC’ inlets or ‘MSD Inlets’ grouping.
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3. Again, use naming convention that relates back to the structure you are
creating (e.g. ‘CBI TY B Ahd Plan 10’ for a CBI Type B that intercepted
flow going up station and had 10-foot throat).

4. You will need an element template for the

a. Planview,

b. the top phasein 3D (this is not required for headwalls), and

c. the bottom phase in 3D

d. Note that in the figure above, the plan view and top phase for a
curb box inlet are shown. The bottom phase is shown in the
‘Vaults’ Section as shown on the next page.
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-l Vault 5.5¢3.5

il Vault 5 5xd

-l Vault 5.5:4.5

-l Vault 555

-l Vault 5.55.5

-Jl Vault Gx3

-l Vault B35

- Vault Gxd

[l Vault Bxd.5

- Vault 65

-l Vault 6x5.5

Ji Vault GG

@ Spring Box Type A Vault
-J@ Spring Box Type B Vault
J Vault Type 11

--J& Vault Type 10

Properties

General Settings

Levels
Colors
Line Styles
weights

Cell settings

Active Cell
Scales

Material Settings

Material
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5. Go to the Element Template for the plan view. We are going to tell it
which cell to point to.
a. Right click under the ‘General Settings’ box and click on the
‘Add’ button.
i. Click on’Cell’>’Cell Name.

1. Click on Active Cell pulldown and select the 2-D
cell created in Step 1

2. If *.celfile is in the right location, it should be
available in the pulldown.

3. Tip - if at this point, you cannot find your cell
name, and your Cell file is in the correct
location, go back to your cell file, and check the
properties of the Model the cell resides in,
make sure the property "Place as Cell" is set to
"True" otherwise you will not see it in the list,
this goes for 2D and 3DThis is mostly for new
cells created with the seed files, because the
KYTC set the default model to not be placed as a
cell.

ii. Right click on the same area and click ‘Add’>'Cell’>'Cell
Scale’. Keepon1,1,1
iii. Can also right click and add material.
1. Have a predefined list of materials to pick from
6. Do the same for the Element Templates for the 3D Top Phase and
Bottom Phase (bottom phase only for headwalls).
a. Note for Inlets like the CBI Type A and Type B, the bottom Phase
Element Templates are in the ‘Vault’ subdirectory. The point???
Tops, Bottoms and plan view Element Templates can be in
different subdirectories.
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8. Set the Solid Symbologies (sets the 3D part of Feature Definition)

a. Under the ORD ‘Explorer’, under ‘OpenRoads Standards’, go to ‘Feature
Symbologies’>'Solid’

a Drainage and Utilities ~ 8~ H“._. L j =l = KYTC_Drain_Levels Featur

Home Layout Analysis Components Utilities View Tools Report Drawing Production Drawing Utilities Co

[— i

= S T
2 New Template * | |[R_PL_FEAT PR "] Q) B < k + i | oo P i
=l

] ~|[= ¢ Y |[= my Ty a—— n = | Expl Attach - El t Fence Civil Terrain
E s = v =1 Q@0 = PO ool v oI Sel?;t?gn Tools~ B = | Analysis - Import ~

Attributes Primary Selection Model Analysis

| Explorer > ox
File

¥ Items

B View 1, Default
Em-dig-|d PLPLRPOYD B M

B Resources
CpenRoads Model
L5 SheetIndex
e Links
OpenRoads Standards
QQr.
4 " Standards
b |8 Libraries
r KYTC_Drain_Levels_Feature Definitions_Annotate_Elem
> Feature Definitions
4 Feature Symbologies

P ¢ ¢ ¢ ¢ ¢

b " Linear

b+ Paint

b. There are several subcategories under ‘Solid’

| OpenRoads Standards -~
. ) Q‘ ,@ -
> ¥ Point -

> 1 profile

4 &y solid

b Conduit
4 Drainage
b Headwalls
4 Node
b CommunicationsNede
4 Drainage
b Cross Sections
b Headwalls
4 Inlets
b Curb Inlets
b Crop Inlets
b Median Inlets

Junction boxes
Manhales

Spring Boxes

v v v v

Transitions
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c. Headwalls are under ‘Solid’>’Drainage’>'Headwalls’.
i Everything else in drainage is in ‘Solids’>’Node’>'Drainage.
ii.  There are Solid Symbologies for other elements that are non-drainage related
as well (e.g. utilities)
d. Once you have selected the desired subcategory, right click on it and select ‘New Feature
Symbology.
i Right click on this new feature symbology and select ‘Properties’.
ii. Gotothe ‘3D’ section.
1. For ‘Top Template’, select the template you created in the previous
section of this document (Section 6)
2. Do the same thing for the bottom element.
3. Headwalls should only have a Bottom Template. Top template should be
set to ‘None’

—— 11 v = a - = PR E £ = - - F A — Drawing

4[] Selection (1)
" < New - Ar
Mod

Selection -
Name New

Defaults ~
Default Element Template JNone

3T

< Top Template Drainage\Storm Modes\Inlets\Curb Inlets\Type B\Curb Inlet Type B Top
melate Drainage\Storm Nodes\Vaults\CBI A\Vault 65
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9. Set the Point Symbology (sets the 2D part of Feature Definition)

E’J Drainage and Utilities v - H l‘._. I_fL * - ; = - KYTC_Drain_Levels_Featur
Home Layout Analysis Components Utilities View Tools Report Drawing Production Drawing Utilities Co
= | New Template * |[R_PL_FEAT PR - q E: =~ k i : .ﬁ&*
i B MIER N g 17 |@o ~|&mo - Eiplorsy "I.'.-;t;?:-d'1 s T '_'J A SEEI\EETSQE '[Foeon\zcé B Analysis ‘rleprgari:n'
Attributes Primary Selection Meodel Analysis
e
N 't -
i Explorer T X View!, Defaukt
1 File v G- 4 PPROGD EIERY
@ Items hd
& Resources A4
| OpenRoads Model L4
§ Sheet Index v
% Links v
OpenRoads Standards A
Q@P.
4 " Standards
> A Libraries

Fl KYTC_Drain_Levels_Feature Definitions_Annotate_Elem
b Feature Definitions
- Feature Symbologies
i

2

b 4 Solid

a. Again, there are several subcategories under this category

4 Feature Symbologies

[ " Linear

4 ¢ Point

4 Drainage
[ Cross Sections
[ Headwalls
A Inlets
4 Curb Inlets

&% Curb Inlet Type F

] Type Aand B
b Ahead
Back
4 Sag

€, CBl A Sag 10
@ CBIE Sag 10

[ Niran Inlets
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b. Once you have selected the desired subcategory, right click on it and select ‘New Feature
Symbology.
i Right click on this new feature symbology and select ‘Properties’.

ii. Go to the Plan and select the 2D Plan Element Template from the previous
section of this document (Section 6).
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10. Create Feature Definition

a. Under the ORD ‘Explorer’, under ‘OpenRoads Standards’, go to ‘Feature Definitions’

i.  Again, there are several categories and subcategories where feature
definitions can be located.

B View 1, Default

& File I~ d PO0O060 3 ¢

¥ Items
) Resources
& sheet tndex
% Links
OpenRoads Standards
Qar.
4 "9 Standards -
> [@ Libraries
4 [/ KYTC_Drain_Levels_Feature Definitions_Annotate_El
4 Feature Definitions
b v /" Alignment
By Terrain
i coridar

EF Superelevation

-
v
v
OpenRoads Model v
v
v
-~

€ Linear Template
B Surface Template
£ > ¥ & Linear
¥ Point
A Mesh
Bl Survey
3 % Site
> [ Analysic
Fl &, Drainage and Utilities

P> & = Conduit

b ¥ [ Drainage Area

ii. For drainage structures, they are generally under ‘Drainage and
Utilities’>‘StormWaterNode’
1. Subcategories under this include.
a. ‘Channel Nodes’

b. ‘Headwalls’

c. ‘Inlets’

d. ‘Junction Boxes’
e. ‘Manholes’

f.  ‘Outfalls’

g. ‘Spring Boxes’
iii. Once you determine where the feature definition will be located, right click on
this subcategory, and select ‘New Feature Definition
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iv. Right click on the new feature definition you created.
1. Under Feature Definition, give:
a. alogical description
b. Aseed name (under ‘Name Seed’). This will allow for
numbering structures that are the same (such as MH-1, MH-2
for manholes).
2. Under ‘Node’:
a. Select a default height (default depth of structure)
b. Make sure Structure Type is correct (Inlet Grate, Manhole,
whatever best describes the feature definition).
3. Under ‘Hydraulic Prototype’ — pick the ‘Prototype’ that was created in
step 5
4. Ignore ‘Items (this is for Item Types, which KYTC is still working on with
Bentley).
5. Under ‘Symbology’:
a. Point Feature Symbology — Select the 2D Feature Symbology
that was created in Step 8
b. Connection Regional Feature Symbology
i. Select pulldown
ii. Select ‘Linear’
iii. Select ‘Connection Region Feature Symbology’
c. Solid Symbology — Select the 3D ‘Solid Symbology’ that was
created in Step 7.

11.The feature definition is now ready to be placed in your ORD design DGN!
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